PreSonus Blog

OS X 10.15 Catalina Updates

Hey PreSonus users!
We released a few updates today in support of Apple OS X 10.15 Catalina that we would like to tell you about. Universal Control v3.1.1, Capture v3.0.2, and Worx Control v1.4 have all been released and now include Catalina support. Current mobile App versions already support iOS 13, so there is no need to update them at this time.
Please note that  StudioLive 16.0.2 USB users will need to update their firmware via Universal Control 3.1.1 in order for USB audio to function correctly on OS X Catalina.

Version Information:

  • Universal Control (Mac/PC) – v3.1.1.54569
  • UC Surface (iOS/Android) – v3.1.0.53214
  • Capture (Mac/PC) – v3.0.2.54569
  • Worx Control (Mac/PC) – v1.4.0.54335
  • QMix-UC (iOS/Android) – v3.0.0.5152
  • StudioLive 1602 USB – XMOS v0.05
Supported OS Versions:
OS X 10.11.6 (El Capitan) or later
Windows 7 (x64) Service Pack 1 + Platform Update, Windows 8.1 (x64), Windows 10 (x64)
Please see the Release Notes for this Universal Control update for further details.
For Studio One users, don’t forget: Studio One version 4.5.4 is required to run Studio One under 10.15. There are also a few known issues at the time of this writing with some of the Studio Magic plug-ins.
  • Izotope Neutron Elements and Klanghelm SDRR2Tube will not install under 10.15.
  • Arturia Analog Lite and StudioLinked Trophies will at first not install—you must CTRL+Click (or right click) and select “Open” to install them.
  • Check your third-party plug-in developers’ websites for updates, as many of them may not install or run correctly under 10.15, and will need updates themselves to work correctly.
  • Some of the Studio Magic Plug-ins will not run under 10.15.
See our original Catalina blog post for more info.
  • Please sign in at my.presonus.com and submit a support ticket and we’ll help ya out.

  • Travis Goldie

    so ive downloaded 4.5.4 but i still cant add that to having security access to my microphone???

  • Serge Davidov

    Same here! Thanks for your comments!

  • K W

    Yes. You just need to download and install the latest version, 4.5.4 (or update directly from within Studio One). I am not on Catalina yet, because so many of the manufacturers of the third-party plugins I use have not come out with Catalina compatible updates yet.

  • Serge Davidov

    That means it is already done!?

  • Haavard Flaaten

    So my Studio 18/24 USB will work fine with Catalina now?

  • K W

    Reading the actual words in this blog post, I sense this might hold the answer to your question: “Studio One version 4.5.4 is required to run Studio One under 10.15.”

  • Serge Davidov

    Any estimated date for Studio One compatibility? Tnx in advance